Jump to content

Using an Autonostics/Vag-Com Cable To Read/Flash ECU's


Recommended Posts

Figured that we should start a new thread for flashing so we don't confuse people who are just trying to log. This thread will discuss anything related to flashing with OS software. We can also include the use of the RR map editor in this thread too.


Here is the quick rundown of the steps needed to read or flash the ECU using an Autpnostics or VAG-COM cable other than the Tactrix cable. I will get screenshots eventually and post them here too. A couple steps are just little things to make sure it's hassle free. Some people may flip a couple steps around, but this is my basic ritual when using ECU flash.


Warning!!NEVER try to Read or Flash the ECU if ANY other program/driver has locked up since the last reboot! This can cause the PC to lock up in the middle of an image and that's not good so please only do this if you understand the risk involved and are willing to accept it. Again, failure to follow these procedures to the letter may result in a "bricked" or unusable ECU. You are doing this at your own risk.


Here we go:


1. Get in the car.


2. Connect the GREEN "TEST" connectors that can be found just a hair to the drivers side of dead center behind the glovebox. They are tucked away in a little compartment behind the top of the carpet. Find them and connect them.


3. Reboot the computer and/or let it completely boot up.(Just to make sure the drivers are all clean)


4. Connect the OBDII end of the cable into the car's OBDII port if it isn't already. The OBDII port can be found below the dash on the driver's side off to the left of center.


5. Connect the USB end into the computer and wait a few seconds. It takes the computer a few seconds to find, recognize and load the driver for the cable.


6. Turn the key to the "ON" position. At this point the dash should light up like a Christmas tree, the fan should start cycling on and off.


7. Start ECUflash, You should be able to select Read from the file menu.


8. A window will pop up. This looks like a logging window, but it actually wants you to select your ECU/Vehicle, so select your vehicle class from the list.


9. Click the button at the bottom of the pop-up windowand it should start reading and logging progress. Your odometer should read "ErHC" after you connect to the ECU.


10. Once the image is read or burned, you can exit ECU flash and turn the key to the "OFF" position.




12. Turn the key forward and wait until the seatbelt dinger stops and then start the car. Any time the ECU is reset or re-flashed; it needs to re-boot. This is done when the key is first turned to the "ON" position and takes about ten seconds. If you don't wait for the re-boot; you will just be cranking and wearing down your battery until the ECU is ready to go, so just be patient and wait for it.


13. Enjoy!



If you still need to install the drivers for your cable or get it configured correctly please read below. This is taken from my other thread "Using the Autonostics Cable to Datalog": http://www.legacygt.com/forums/showthread.php?t=96737&page=6


Here is what you need to get started:


First off you will need a driver for the cable that is not included with it. This is the winXP driver we use: FTDI 2.04.06


Others are available here : http://www.ftdichip.com/Drivers/D2XX.htm

Extract the .zip file and remember where you put it as you will need it when you plug the cable into the usb port and the install box pops up. During the driver install; point Windows Installer to the folder where you placed the unzipped files and install the driver.


You may need to adjust the cable's/driver's COM port settings in order to get it to work properly:


1. Go into Device Manager for Windows(right click "my computer" on desktop, go to Properties, then Hardware tab and click "Device Manager" button)


2. Look under ports(COM and LPT) for the FTDI port(cable must be plugged into the computer at this point) and right click and go into properties for the FTDI cable driver.


3. Go to the Port Settings Tab click the ADVANCED button and look at the BAUD Rate. If it is 9600; you will need to drop the box and change it to 4800.


4. This should slow the data rate of the driver/port and allow the cable to connect to the car's ECU properly. Be sure to note the COM port number assigned to the FTDI port as you will need to select it in the logging software.


The ECUflash I used to read my ECU image/ROM is available here: http://www.openecu.org/index.php?title=EcuFlash













However, if you have done ANY research into the subject; you would already know that. That is the reason they created the Tactrix v2 cable...

Edited by qikslvr
Let's kick this pig!
Link to comment
Share on other sites

  • Replies 217
  • Created
  • Last Reply

Top Posters In This Topic


Just trying to keep the logging and flashing discussions in different threads so newer users don't confuse any of the instructions or troubleshooting. As always, feel free to add anything that you do differently or correct me if I missed something. Most of these walkthroughs are written off the top of my head. Screenshots are in the works for both this thread and the loggin thread.

Let's kick this pig!
Link to comment
Share on other sites

Thanks. Just trying to keep things clean and get it all in one post while keeping logging and flashing apart so no one gets confused. I'll go back and collect as much of the logging info as I can and put in the first post of that thread too so I have a complete walkthrough in one post there too.
Let's kick this pig!
Link to comment
Share on other sites

anyone have intermittent issues with the VAG-COM ? in my stage 2 logs thread mickeyd mentioned something about it looking like my logger cut out at spots.


edit: doh! guess this should have gone in the logging VAG-COM thread.

Link to comment
Share on other sites

Hi guys,


For some reason, I'm having difficulty reading a 2006 Non-USDM Legacy GT 2.0T DBW ECU...can someone please help?

I found to green connectors...one on the drivers side, behind a cover by the accelerator pedal (this was originally disconnected)...then another on the passenger side, underneath the glove compartment on the right (this was already connected).

I joined the driver side green connectors...turned the ignition, and the fans engaged just like always when in test mode.

I presume there is no need for a white connector like the WRX's and STI's?

I also found a small white connector on the drivers side, which was disconnected...does anyone know its functionality?


Learning View works fine on the car, and a would only guess that I'd also be able to datalog, but I cannot read or flash the ecu...hmmm???


Can someone please advise if I'm doing something incorrect?


Any help would be greatly successful.




Edited by Phoenix*
Link to comment
Share on other sites

  • 2 weeks later...








However, if you have done ANY research into the subject; you would already know that.

Edited by qikslvr
Let's kick this pig!
Link to comment
Share on other sites

  • 3 weeks later...
  • 1 month later...

Need help trying to figure this one out. I've read both the Autonostics threads inside and out trying to find someone with the same issues I'm having. Found a few, but they didn't give a clear anwser to how they fixed it.


Using the VAG COM (blue) cable.

Installed all recommened programs including updates (RR, LV, Ecuflash).

Followed instructions step by step


Here's what works:

RR works fine and able to log stock runs

LV works fine and able to reteive ECU info, IAM, etc...


Here's what not working:


Connected green connectors

connected VAG COM cable from ECU to laptop

Turn car to "on"

Start ECUflash "Read" program

Message states: Unable to connect to vehicle interface. Interface close.


Not understanding why the other programs work great and the ECUflash doesn't. Anyone know of a fix??? Thanks.

My wife's balls are delicious.
Link to comment
Share on other sites

Excellant, it worked!! Uninstalled ECUflash 1.42 and installed 1.29 version. Works perfect, now I'm able to Read, Write, Test and Compare thru ECUflash.


Thanks Silverstar:)

My wife's balls are delicious.
Link to comment
Share on other sites

qikslvr, thank you very much for helping to pave the way for the rest of us. Based upon your work, I purchased an ebay vagcom cable a while ago and was able to log without issue. I am now trying to flash using version 1.29a of EcuFlash and running into problems.


Here is the log of what I am getting in EcuFlash when I try to read the rom after selecting the 04 DBW STi, etc.:


[00:03:43.500] Version 1.29.906

[00:03:43.500] 8 memory models read.

[00:04:06.921] 305 ROM metadata models read.

[00:04:06.921] checksum module "subarudbw" loaded.

[00:04:06.937] flashing tool "wrx02" loaded.

[00:04:06.937] flashing tool "wrx04" loaded.

[00:04:06.937] flashing tool "sti04" loaded.

[00:04:06.937] flashing tool "sti05" loaded.

[00:04:06.937] flashing tool "mitsukernel" loaded.

[00:04:06.953] flashing tool "mitsukernelocp" loaded.

[00:04:06.953] flashing tool "mitsubootloader" loaded.

[00:04:35.687] unable to open OpenPort device [ Serial ].

[00:04:35.687] unable to connect to vehicle interface.



Any idea what the issue could be? I've tried both updated and non-updated EcuFlash definitions. I have verified that I am using the cable driver that you linked to in your OP. I have also verified that the baud rate is set correctly. The green connectors have been connected under the dash by the steering wheel. There is no flash block (I dont think) since this is on an '04 STi, which is drive by wire.


I'd appreciate any advice that you could offer for how to solve this problem. Can't think of anything else to check!



Link to comment
Share on other sites


Had a customer experience the same problem recently, turned out to be the connectivity between Ecuflash and the cable (possibly drivers???). It would never connect to the ecu via ECUFlash however worked fine with Romraider.

Link to comment
Share on other sites

Also I'm getting a 404 error "file not found" message when I try to download version 1.34 from the page specified. I'll try using the Tactrix driver instead of the FTDI driver which was recomended in the other thread.
Link to comment
Share on other sites

Ok, that worked, I was able to run Learning View, ROM Raider Logger, and read the OEM basemap with the current version of ECUflash using the Tactrix drivers and the VAG-COM cable. Now I guess I better get busy and actually install the new parts.


Thanks to GateTwelve for the tip on using the Tactrix drivers and the current version of ECUFlash. And thanks to qikslvr for starting and maintaing this thread!


Woowhoo, this has saved me a boatload of money now that I don't have to buy the Tactrix cable.

Edited by scottj
Link to comment
Share on other sites

  • 2 weeks later...
Link to comment
Share on other sites

Finally succeeded after lots of trial and error. Winning combination was Win XP system w/ ECUFlash 1.29a and FTDI driver for VAG-COM cable :-)




do you have a blue one? Still haven't gotten mine to work yet even with older versions of ECUFlash

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Create New...

Important Information

Terms of Use