Jump to content

Misfire..no codes unable to fix TRIED EVERYTHING.......

Recommended Posts

Hello I am new to the forum, and someone is probably going to complain about starting yet another thread about this... however I have searched high and low on here to find the solution.. so I am going to give it a fresh start... I purchased the car recently with 120k miles on it. the car had a very severe misfire and was in limp mode. I figured that it was due to the crack in the intercooler causing a massive vac/boost leak... So I bought the car and replaced the intercooler.. better but not fixed. Now the problem that will not go away is that when idling in gear it has a miss/idles low.when driving under slight acceleration it has a miss sometimes. WOT seems normal cant tell if the turbo is covering up the issue, or if it goes away under full load occasionally stalls during the initial start up if you put it in gear as soon as you start it. no codes. I went thru the basic diagnostic steps..

*cleaned the maf/ switch with known good one

*new plugs and coil boots. no change

*pressure/ leakdown test on the injectors good pressure and it holds after you turn the car off

* checked the wire harness and ecu plugs.

*smoke tested the intake and vac lines. no leaks

*compression test( found dead cylinder#2 40 psi) cyl leakdown test all other cyls ok #2 warped exhaust valves (im assuming due to the previous owner driving with a cracked intercooler.)

*machined the heads and full valve job new timing belt. check OVC and AVCS remove those pesky oil banjo screens) no change.

*cleaned the throttle body (sprayed with cleaner and wiped out the intake/butterfly)

*smoke test again after reinstalling engine no vac/ boost leaks

*took to the dealer they couldn't figure it out

*took it to a subi speedshop for data logging. they recommended a front 02 and said it retarded the timing at WOT almost to the point of triggering a CEL.

* new oem 02 sensor.

*reset idle according to subi specs

*checked cam and crank sensors

*created a massive vac leak and the idle initially dropped ( rules out getting to much fuel at idle)

*add propane thru a vac line idle initially drops. again eliminated an air supply issue. or vac leak


............ cant figure it out and its driving me NUTS.

Link to comment
Share on other sites

Learning view? Fkc flkc? and correct it is a 5eat and only happens In drive or reverse, I was thinking maybe the torque converter is locking at idle but I have crossed that off the list because the problem seems to be that it misfires under slight load.
Link to comment
Share on other sites

See this first post here: http://www.romraider.com/forum/topic2772.html. It gives some good basic info about learning view, and 'feedback knock correction' (fkc), as well as 'fine learning knock correction' (flkc).


Essentially, it is a way to see how your air fuel ratio is in various conditions (e.g. idle, under load, cruising). This way, you can easily get some indications of boost/vaccum leaks.

It is also an easy way to see where the ecu has pulled timing due to knocking (i.e. under what rpm and what load ranges).


I personally use this tool to monitor everything: http://legacygt.com/forums/showthread.php/btssm-bluetooth-adapter-app-229709.html

Link to comment
Share on other sites

Yes actually I do believe they were the orange ones, but I think They aren't leaking because I smoke tested the intake, and also sprayed the entire engine with starting fluid. And it's possibly a loose wire I haven't tried ohming each wire from the harness. I'm hoping to try switching the coils with the ones I have in my outback, I'm wondering if it's a computer programing error. This seems to be a problem that is very common on this generation of legacys.
Link to comment
Share on other sites

Are you losing any fluids?

Have you done a leakdown since fixing the valve issue?

Because I've had similar issues twice with no lights. Once was a 2x blown pistons (lots of oil use), the other was a cracked case at piston #3 (loss of coolant). FML.

A blown HG can also cause some issues like this. Possible that got messed up when you did the heads?

Link to comment
Share on other sites

Twist the pins in the ignition coils slightly with needle nosed pliers. They are flat pins and the female ends inside the harness plugs loosen over time. Twisting then slightly causes them to be tight again. A very small amount of dielectric grease on the female side and snap them back in.
Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...

Important Information

Terms of Use