Jump to content
LegacyGT.com

Tuning out Fueling stumble - ideas?


Flinkly

Recommended Posts

First new thread for me in some time, but i'm tired of chasing my tail with this "stumble" issue i have, and am almost certain i caused it. while i didn't do much logging of how things were prior to these changes, after i swapped in by DW850's i started having this issue.

 

To me, it looks like i've got a latency/scalar problem interacting with engine harmonic. Looking at the stock injector pulse width compensation, it's obvious where the large spike is coming from - the harmonics (or else the stock rom's way of dealing with it).

 

The idea i have now is that maybe my latency is too low and my scalar is too low, and the per injector comp table just isn't adding enough since it's multiplied by the base pulse width. follow?

 

irregardless of what i think is going on or what might solve it, i'm completely open to ideas, speculation and opinions. brand new STI regulator has been purchased and tried and ended up with the same spike in relatively the same space. willing to try it again though. :)

 

I also had a Walbro when i started this and now have a DW65c with a brand new filter housing. no other fueling mods, and only a Cobb catted DP otherwise.

 

First image is stock Per Injector Comp tables and the second is RPM vs. Correction (learning "deactivated", so captures total fueling correction).

 

Currently running 850 for scalar and somethign around .92 for latency at 14V. idle is pretty much a 50:50 split between pulse width and latency.

IPWC.thumb.png.f07c5c2c85bbca664b4ee4e37f8be417.png

RPM-Corr.thumb.png.7e211f6ca9cfa27222de8307dad1d40f.png

* Build Thread * 26.53 MPG - 12 month Average *
Link to comment
Share on other sites

I had a very similar plot from my old injectors. I am not sure whether they were DW850s or Perrin 816s... don't think the seller knew either, but I didn't find that out until later.

 

Anyway, I worked around it with the open loop fueling table, but your approach is probably better.

 

However, the problem went away when I switched to ID1000s a couple years later, and I also saw noticeably fewer random knock events in my logs, so I think that's really the best solution.

afr-maf-1.PNG.01fa94eab0ff251dc68d8a6dd1df5a86.PNG

afr-rpm-1.PNG.d6ac04fdd3fc64d50a9604ea18cc67e0.PNG

Link to comment
Share on other sites

When you guys are just cruising around are you getting a lot of AFR sway? My legacy is much more precise at keeping at 14.7 range then my other cars were. That's on stock fuel pump and yellow injectors.

 

I do have the stumble at 2-3k rpm when going up a hill and when the car is still warming up. I've been thinking about messing with the tune too. I feel like my stumble is happening due to leanness for the amount of load.

05 LGT 16G 14psi 290whp/30mpg

12 OBP Stock 130whp/27mpg@87 Oct

00 G20t GT28r 10psi 250whp/36mpg

Link to comment
Share on other sites

at cruise rpm it does really well. it stumbles and is eratic as i get to and pass the 1750rpm point/peak as i head to a shift point or cruise speed. seems to be some discrepancy in per injector compensations, which seem to be off due to latency and scalar errors (or just changes in harmonics due to shorter pulses, due to larger injectors).

 

hard to tell with all these compensations being dumped on the final PW...

* Build Thread * 26.53 MPG - 12 month Average *
Link to comment
Share on other sites

Are you getting any FKBC at around 1750rpm? I get a ton of what seems like false knock at that RPM and ~0.70-1.00 g/rev. This results in up to -12ign, which leads to odd hesitations obviously.

 

The question is, did 16bit cars have this issue, with any injectors? We seem to have this issue across board, stock fueling or not, just curious what changed.

05 LGT 16G 14psi 290whp/30mpg

12 OBP Stock 130whp/27mpg@87 Oct

00 G20t GT28r 10psi 250whp/36mpg

Link to comment
Share on other sites

Mine stumbled a bit below 2500 if I remember right. Changing the fuel pressure regulator's pressure signal from the stock location (on one leg of the manifold) to the center / plenum fixed it. It's actually tee'd into the line that goes to the BPV, and the nipple that the FPR used to connect to just has a few inches of hose that terminates with a bolt stuffed in, and secured with a zip-tie.

 

I tried a bunch of stuff to get rid of that stumble (replaced FPR, switched to an aftermarket FPR, put pulse dampers in different places, used a tee to add a two-foot-long hose in hopes that it would absorb pulses... nothing worked. But when I moved the FPR's pressure reference the stumble went away.

 

I get some occasional knock-sum increments during cruise but never enough to matter. If I wasn't looking at logs, I'd never have known about it.

 

In cruise, the AFR oscillates +/- a couple tenths, like clockwork. The ECU does it deliberately to facilitate two different chemical processes in the catalytic converter, there's an SAE paper about it somewhere. You can watch it in the logger using the "AF Correction #3" parameter. It hasn't ever been a problem so I haven't changed it, but there is a table or two to control it.

 

I don't think it's in the main definitions yet but there's a thread about it, with definition info for lots of cars.

 

http://www.romraider.com/forum/viewtopic.php?f=40&t=8131

Link to comment
Share on other sites

i'll have to do a log to check on the FKBC.

 

most of my false knock seems to be when i lift off the throttle (shifting, coasting to a stop, etc.). might be from tip-in/out issues or just random false knock.

 

as for oscillations in AFR due to the CAT, i've disabled that in my rom, so my AFR is free from those swings.

* Build Thread * 26.53 MPG - 12 month Average *
Link to comment
Share on other sites

I actually have AF 3 feedback disabled too, for a while my downpipe didn't have a bung post the cat (just a useless 2" before cat one all the way back).

 

Today I tried to do a data log while the car was cold and go up a hill where it would usually hesitate, and of course it didn't do it at all. Part of me wonders if this hesitation is TGV related for me.

 

As for knock, I would see FKBC while in higher gear (4th) going around 30mph and trying to maintain/pickup speed, that puts me at ~1700rpm. It would only happen after I drove for a while in the city. I recently changed out my spark plugs from 6's to 7's, maybe that will help.

05 LGT 16G 14psi 290whp/30mpg

12 OBP Stock 130whp/27mpg@87 Oct

00 G20t GT28r 10psi 250whp/36mpg

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.



×
×
  • Create New...

Important Information

Terms of Use