Jump to content

Car bogs down, accelerates slow and jerky, than surges at about 3,300 RPM's

Recommended Posts

So I recently installed a new motor in my legacy. Before the swap, the car ran great. After the swap, the car is having issues accelerating under load. It idles fine and when its out of gear it revs up smooth, but as soon as I take it for a drive, it bogs down, accelerates slowly, and gets kind of jerky until I reach about 3,300 RPM's than surges and runs smooth.


I've tried installing a new MAF sensor and ECM, but the issue persisted. The one thing I did notice is when I disconnect the ECM for a short period of time and plug it back in, the car drives great for approximately 10-20 minutes than gets progressively worse until the issue completely returns.


Also its seems that when I unplug/plug the ECM while the car is cold it runs great for a longer period of time, as opposed to unplugging/plugging the ECM while the car is warm.


I'm at a loss, so any idea's would be a tremendous help.

Link to comment
Share on other sites

Welcome to the forum.


Sounds like you have a sensor problem. Since you don't have a Check engine light, its hard to say where to start.


How clean are your grounds in the engine bay? Did you hook them all back up after the swap? Double checked that all of the sensors are connected and the harnesses are undamaged? Did you use the old harness in your car or did you swap harnesses? What motor from what year car did you swap in, and what year is your car and what motor did it have before?Did you verify the timing of the engine before you installed it?

Link to comment
Share on other sites

Thanks for the reply's,


So, all the grounds are connected and I made sure they were clean. Double and triple checked all my connections.


The motor was completely rebuilt, timing is correct and I'm using my original wiring harness that had no issues prior to the install.


Also I have a 5spd, and I replaced the clutch at the same time as the motor install.


I figured it must be a sensor issue. I tried disconnecting my o2 sensor to keep the car in open loop, but the car ran exactly the same.


Does anyone know which sensors wouldn't throw a code?

Link to comment
Share on other sites

Yeah my cel works, and I've hooked it up to a scan tool, and didn't find any codes.


It feels like it's in limp mode, that's why I started to think it might be the o2 sensor, but the car ran the same with the front o2 disconnected.

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...

Important Information

Terms of Use