Jump to content

V3 Cobb issue


Recommended Posts

I can't install my Cobb v3 sub-002. When I try to install it for some reason it doesn't recognize the "key on". Basically stuck on the screen where it says "verifying key on".

The green plug is plugged on and I tried with it off.

Firmware is up to date aswell.


Has anyone ever experienced this before? Help please.

Link to comment
Share on other sites

Have you talked with Cobb ? They have great customer support and quick turn around if needed.


They sent mine back the same day the got it for repair.

305,600miles 5/2012 ej257 short block, 8/2011 installed VF52 turbo, @20.8psi, 280whp, 300ftlbs. (SOLD).  CHECK your oil, these cars use it.


Engine Build - Click Here

Link to comment
Share on other sites

give COBB a shout directly they are amazing and will get you sorted out quickly. i recently worked with them to diagnose a error code when trying to read engine codes using a V3 on my 5eat. the latest firmware update corrects the issue, i tested beta firmware for them to make sure the problem was solved!
Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...

Important Information

Terms of Use