Jump to content

Programming key fOb problems

Recommended Posts

First of all, i did search the h*ll out of this but havnt found solid solutions.


Ive been trying to program a new key fob, followed procedures but....nothing. And now my dome light simulates a disco until doors are closed.


Correct if im wrong but procedure for programming is:

1. Open door

2. Turn key on

3. Hold button til locks cycle and keep holding

4. Press lock button on fob

5. Turn off and test out


Thats correct right? It did not work for me. Can somebody shed some light on this dilemma?

Link to comment
Share on other sites

Found this on cars101.com


Doesn't look like mine for my '99, but who knows...

Programming or Overriding the Alarm when you have lost the remote

Open driver's door.

Turn ignition key to 'On'

Press and *hold programming button* in (see diagram, button under dashboard)

After 15 seconds the the door locks will cycle 3 times. Do not release Programming button

Press lock (left) button the remotes to be programmed. The door locks will cycle one time.

Exit programming mode by releasing Programming button under dashboard and turning key to off.


http://www.cars101.com/subaru/codealarmremote1.JPGCode Alarm Programming Button is under dashboard on the kick panel by the driver's left knee, left of the steering column. If you can't find it, it might still be tucked up in the wiring harness higher up in that same general area. The button is recessed in a plastic ring (see diagram).

This button must be pressed while programming remotes or if the battery was disconnected and the lights are flashing.

Link to comment
Share on other sites

could be the unit is bad, or it was installed wrong, or it isn't a factory unit, or any number of things.


i don't think i can help any more, but i'll be interested to learn your solution.


does the key on /off 3 times fast do any thing?


do you have the red button on the dash next to the fog light switch, or the rear defrost switch?

Link to comment
Share on other sites

well the red button is the ''valet mode''. basically it turns the alarm off so some one can park your car with having access to the alarm.

you might try activating / deactivating that if you have not tried already.


the fob you are trying to program looks like the one that worked before?

Link to comment
Share on other sites

Yeah i got it. What solved it was, my red "security light" next to the foglight button wasnt a button. Pulled a red security light button from another legacy and wired it in.


Followed the same programming steps and held in the red security light button amd now my fob is programmed and functional!! ....only now my dome light is extremely dim or doesnt come on at all.... But it doesnt flicker anymore

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...

Important Information

Terms of Use