Jump to content

writing to ecu problems


Recommended Posts

so i have a CEL for my rear O2 sensor. i have already disabled the rear O2 and wrote it to the ecu twice. about 20 mins worth of driving later it comes back on. i hook up my laptop and read the ecu, check the diagnostic codes and the rear O2 (P0420) is no longer disabled. any ideas what im doing wrong?



heres my process:


1)connect test plug (green plug under dash)

2)hook up OP 2.0 cable

3)put key in and turn to on position (fans begin cycling)

4)connect to ecu

5)read from ecu

6)open diagnostic codes

7)check the box for the rear O2 (P0420) (a little window opens saying the code is disabled)

8)i write to ecu

9)it says write complete

10)turn key off

11)un hook OP 2.0 cable

12)unplug the test plug



then i turn the key back on, start the car, the CEL is gone. i go for a drive for about 20 mins across town, it comes back on.



any ideas??? i really want to get rid of it. thanks for any and all help

Link to comment
Share on other sites

While not connected to the car, open the rom image you downloaded in RomRaider ECU Editor. Find and disable the code on the left hand side. Save this rom image (preferably with a new name). Connect to car and open ecu flash. Open the rom that you just saved and write that to ecu.
Link to comment
Share on other sites

oh, so i have to disconnect from the car then disable it, then reconnect. i got it.


i have been downloading the rom from ecu flash. i dont know why my rr ecu editor isnt working properly, i have all the ecu definitions downloaded. when i try to open a rom with RomRaider which i downloaded and saved with ecu flash, RomRaider says "ecu definition not found." which doesnt make sense. i tried downloading the newest version of the definitions, but i already have the latest versions.

Link to comment
Share on other sites

^ Agreed. If you can't get RR to work, you can edit the rom with ECUFlash. Just make sure you're saving the rom image (preferably with a new name) and then flashing that newly saved image. I think this was the step you were initially missing.
Link to comment
Share on other sites

  • 6 years later...
  • 1 month later...


This topic is now archived and is closed to further replies.

  • Create New...

Important Information

Terms of Use