Jump to content
LegacyGT.com

Crank but no start


Recommended Posts

Hi everyone

 

just starting to work on my 05 Legacy GT. Previously I have only worked on BC legacy's so all the electronics is proving more challenging.

 

I bought it as a non running vehicle.

 

So far I have:

 

- replaced the intake

- replaced fuel pump

- replaced coils

- replaced spark plugs

- checked for codes

 

It cranks but doesn't fire...

 

Any ideas on next steps?

 

Cheers

Edited by blk_legacy
Link to comment
Share on other sites

Do you have rpm signal? Sometimes you will see the tach move but a scanner would be best to use as it will only be around 200 rpm. If you have rpm signal, check for spark and fuel. Does the motor sound like it has good compression when cranking?
Link to comment
Share on other sites

Hmmm not rpm registering on the gauge.

 

I'll get a scanner in the next few days. (Any recommendations?)

 

I just noticed that the check engine light blinks whilst cranking. So hoping a scanner might pull something up.

 

Compression sounds good.

Link to comment
Share on other sites

Ok found that the ground on the engine wasn't connected so bolted it up.

 

Also, the knock sensor was loose so tightened that. Wow that's a tough one to get at.

 

Checked the cranking voltage, battery is at 12.7 (new battery) but drops to around 11.5 whilst cranking. Any idea if this is expected? Could the starter or alternator cause this?

Link to comment
Share on other sites

That droppage while cranking is nothing, my car drops a lot more than that when cranking (1 year old weak oem Subaru battery, I think that's why). I've been down to like, 9.7V while cranking which I hear isn't good, but my car has fired up every time. I think I've heard that anything over 10 or 10.5 volts when cranking is fine.
Link to comment
Share on other sites

I did a little research, and I'm kind of curious to know what the voltage coming from the alternator is when the car is running.

 

P1718 and c0109 are kind of vague, but c0102 has to do with the rear wheel speed sensor.

 

Also, there are two ground straps under the engine, on opposite sides towards the front I think? Doesn't hurt to make sure both of those are good, even though you might have already checked one or both

Link to comment
Share on other sites

Unfortunately that car isn't running to test voltage.

 

However, I have seen some info on P1718 being hit when an auto is moved around in neutral and you can only reset the TCU with a logger/dongle. So waiting to try that.

 

C0102 has cleared now.

Link to comment
Share on other sites

  • 4 weeks later...

OK for those playing at home! Got the VAG cable and ecuExplorer going! Took a little while but once I figured out which USB port and changing the bord rate to 4800 it worked like a treat.

 

 

So we have:

 

P1518 - Starter switch circuit low input

P1151 - O2

P1152 - O2

P0700 - Request AT MIL On

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share



×
×
  • Create New...

Important Information

Terms of Use