Jump to content

97 Legacy Instrument Panel Issues

Recommended Posts

Okay so today I thought I would take a crack at the carbon fiber/colored gauge mod and it went pretty terribly. One of my gauges got messed up and I tried to fix it, but it ended up looking quite a bit different than the other three. The two needles for the thermostat temp and fuel gauge both broke, one of them broke into 3 pieces. Then when I got it all back together, I put my negative battery cable back on and now my running lights won't shut off. Any ideas what could have happened? And does anyone know where I can get another cluster, maybe a JDM equivalent? Any help would be appreciated. Oh, and two of my gauges are off (my fault obviously, just need to be readjusted) but my speedometer is really bumpy and won't show an accurate reading unless I tap the cluster.
Link to comment
Share on other sites

turn off the virgin switch on top of the steering column.

the parking lights will go off.

you are a virgin no more.


buy a new cluster,

and i do not recommend removing the needles from the gauges .

getting my speedo right involved a gps, driving 60mph and working with one hand,

all at the same time.

i do not recommend it.

very dangerous.



sort buy zip code to see what is close.

then by price to find a bargain.

Link to comment
Share on other sites

Okay so I just got a new cluster from a 1999 LGT Auto at a local Pickapart that only has 4K miles more than mine which is perfect, and it also looks a lot better. But after I installed it the speedometer isn't working and thus isn't recording mileage which blows because I like to keep track of my fuel economy and obviously my rate of travel. Any ideas? It is literally identical on the back side, all the plugs are the same. Is there a different reading method for autos or could it be faulty?
Link to comment
Share on other sites

i'm surprised it even plugged in.

i thought the 99 was a ''one year only'' speedo.

different number of wires.

plus it has known issues for failing.


the little blue wire fix.


do a search for 99speedofix, or speedofix.


did you do any research to see if a 99 would swap into a 97?

like www.car-part.com

Link to comment
Share on other sites

I didn't actually do any research I just assumed it was the same. I figured if the clusters were any different I would find out when I pulled it, but I inspected the pins and connectors and didn't find a single difference so I plugged it in to see. I only paid $30 for it so it wasn't a big deal if it didn't work but everything actually worked perfectly (other than the speedometer obviously). I'll probably open it up tonight and see about soldering that ground, and if it checks out I should have a perfect replacement.
Link to comment
Share on other sites

Well I was having an issue with a CEL but I thought it was because of my TPS sensor. I replaced it over the weekend at the same time that I replaced the cluster so I'm actually not sure whether or not it was the cluster or the TPS causing it. It did put my car in "limp mode" though, but it's fixed now.


I ended up just swapping the circuit boards between my old cluster and the new one and now it works perfectly. Here is a picture of the different cluster mileages and one of them disassembled. It took me literally 15 minutes to swap them out, and I went for a nice drive to find that everything is working properly. Thanks Johnegg for your help (on multiple threads)



Link to comment
Share on other sites

  • 3 weeks later...

Just picked up a 97 cluster and I am going to try to swap the internal circuit board into my 99 see if this fixes my dropping speedo.


I did the blue wire fix last October, lasted till about July this year and same issue is back tried to resolder and that did not help.


Lets hope this solves the issues, it was 60 bucks for the 97 cluster so not bad if it fixes the issue


Fingers crossed. Ill update on results once cluster is in and swapped

Link to comment
Share on other sites

  • 2 weeks later...

Update. Tried to swap out the circuit board on the back, it fits in no problem but does not work at all. the board is different an the plug has two wires coming out of it.


Does anyone know what the bottom wire is for? Middle I assume would be the same as on the 99.

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...

Important Information

Terms of Use