Jump to content

Idles for 2-3 seconds, then dies.

Recommended Posts



I got a subaru legacy 1994 2.0 non-turbo. Everytime i start the car it idles for a few seconds, and then it shuts. I can manage to keep it alive by revving it till 3500-4000 RPM, but as soon as i let go of the pedal it shuts. When i disconnect the MAF the car idles alittle bit better, but far from perfect. I bought a new MAF and the problem is the same as with the old one. I got an error on "Cam Angle Sensor", "Abnormal voltage input entered from Air Flow Sensor" and "Oxygen sensor inoperative". Error codes 13, 23 and 32. Any idea what to start with? Its a cheap wintercar, and it will be trashed within a few months, so i dont want to use too much $$ on it.. Any specific cables i should check? Can this be a vacuum leak?


Best regards Stephan

Link to comment
Share on other sites

it may be a disconnected vacuum hose,

it can cause a similar starting problem.

look for the lager hose, big as your thumb,

that runs from the IAC to the plastic intake plenum.

(plastic tube between the air MAF and the throttle body.)

it is hard to see because it connects on to the very bottom of the plenum.


but it could also be the MAF it self.

check the connector at the MAF,

inspect where the wires feed into the connector.

look for mouse damage.??



check the large connectors at the rear of the engine, passenger side.

inspect the pins inside.

look for mouse damage????



all 3 of the trouble codes include the word circuit in the description.

on OBD2 cars this usually indicates a wiring problem.

but OBD1 is more limited and this may not be the case.


but it is odd that you have 3 codes with a possible ''circuit'' problem.

it is possible one bad connector at the rear of the engine is throwing all 3 codes,

and causing the starting problem.


is this a new development,

or did you just get the car?

Link to comment
Share on other sites

Hi Johnegg. Thanks alot for your answer!


I started from the top on the list you gave me. And the first thing i tested worked! Loose vacuum hose as you described :lol:


I got the car like this, and the previous owner said he was sure it was the MAF. I tried looking for bad connectors, bad wires etc, and i actually looked for loose hoses, but didnt see the one you mentioned before you made me aware of it :redface:


Anyways, thanks again for your help!

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...

Important Information

Terms of Use