Jump to content

Cannot log WOT pulls


Recommended Posts

I have done tons of research on this problem with no fix yet. My issue is this; I can flash, use learning view and log normal driving without any issues. As soon as I try a WOT pull, it cuts out anywhere from 3-4.5k. When it cuts out, romraider says "connecting". So far this is what I have done to try and fix:


Load test battery (597 out of 600cca and 12.97v) its good

Check and clean engine grounds (two head to frame and the top of tranny)

Installed 3 ferrite magnets on the OBD harness before plug

Installed 1 ferrite on the vagcom cable after the OBD plug

Disconnected my phone charger

Turned the radio and A/C off


I have tried logging with vagcom and a Tactrix 2.0. I have also tried stand alone SD card logging with the Tactrix and it doesn't turn off but the data is sporatic and repeating. I have included a log from each style and posted them labeled accrodingly.


Any help would be greatly appreciated because I have to start this tune with Cryo.

Vagcom log.csv

2nd gear pull Tactrix USB cable.csv

2nd gear pull Tactrix SDcard.csv

3rd gear pull Tactrix SDcard.csv

Link to comment
Share on other sites

  • Replies 64
  • Created
  • Last Reply

Top Posters In This Topic

OP knows this already, but for everyone else:


As I mentioned in the other thread, a whole bunch of people seem to have this issue too... Can't figure it out. And like I mentioned, I used to have this problem intermittently with an APv2 (silver dongle, sold it already) and my vagcom cable. The problem then completely disappeared with the vagcom after a while.


This guy just posted a thread about his AP having this problem:


Link to comment
Share on other sites

I found an ECU on car-part.com for $125 + shipping. I replaced my old ECU with it and reprogrammed my keys (I have access to Subaru's SSM tool if I ask nicely) with the codes on the small metal tags that came with my keys when I got the car. Flashed it with my map, started it up, and completed a log.
Link to comment
Share on other sites

I'm assuming that the connectors on the OBD2 port itself are wearing down or losing connection. I had this problem sometimes and problems connecting other times. Try picking up a OBD2 extension and plugging the Tactrix to the extension(leave the extension plugged in). That way, when the connectors wear down, you just replace the $20 extension cable.


Works for me...

Link to comment
Share on other sites

Talked to Mike at Tactrix today. He had me send him all of my SDcard logging data. It looks like its an ECU issue as Strizzy encountered. He said that the data loss appears to be caused by the ECU lowering the priority of the OBD port during those times. Therefore, dropping the connection.
Link to comment
Share on other sites

Spoke with Mike at Tactrix again yesterday. He is having me add in "showsample = 1" in the .cfg file to narrow down repeat data. I have also extended the logging interval by 15 miliseconds to help the communication complete. I'll post up results tonight after I log with the changes.
Link to comment
Share on other sites

Eh, try messing with the OBD port anyway. Plug/unplug it a bunch of few times to make sure the contact is good... The OBD port bites onto the cable's pins, not the other way around. So if the OBD port isn't biting firmly or maybe there's corrosion or oxidation, it won't make good contact...
Link to comment
Share on other sites

You tried messing with the pins? I'd be very surprised if this required an ECU replacement being that I had the issue and I still have the same ECU.


Maybe a battery replacement for some reason? Ugh...

Link to comment
Share on other sites

I had the same thing with my $140 EvoScan cable (which now works awesome).

Turned out it was the cord. I Had to crack open the plug and de-solder the cord and replace it with a decent quality printer cable I'd cut the end off. Soldered up the 4 connections it's rock solid now. Doesn't cut out. Before that though, I aslo had trouble getting it to recognise on my laptop properly and it would cut out at revs too.

All good now though.

Link to comment
Share on other sites

  • 2 weeks later...

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Create New...

Important Information

Terms of Use