Jump to content
LegacyGT.com

Good ol' 5EAT Torque Converter Shudder...Or Is It??..


J-Bone
 Share

Recommended Posts

Hey guys,

Long time WRX owner here. Know the ins and outs of GD.

However, this is in regards to my daily.

2009 Tribeca currently with 209kmi

When I purchased it had 152k. In addition to many other maintenance performed on the vehicle, I changed the trans fluid because it was a nasty gray color.

Car ran great for a couple years.

About a year ago I noticed some slight shuddering in 5th with the torque converter locked. The shuddering was at low RPM at around 45mph and under slight load (up hill). Trans fluid was a dark gray color.

After a bit of research, I discovered that there was a TSB on the torque converter for this year.

I pulled the TC and had it rebuilt. Person who rebuilt it said they did not notice anything abnormal in the TC.

I installed it.. still same problem...however now, and over time the shuddering is now felt in 4th - 5th without the TC being locked. And the shuddering is more noticeable. 

I've pretty much come to the conclusion that a full rebuild is required. Now looking back i can assume the dark gray color fluid was from the clutches rather than the TC.

I guess one major question I have for everyone is this shuddering I'm experiencing how these transmissions slip?

I also had the thought that the TC lock solenoid was at fault. But I've not had a code for that appear...

Anyways, any input is appreciated.

I will be performing the rebuild myself and would like to be prepared to replace other components that are causing this issue.

Thanks!

 

Link to comment
Share on other sites

I believe there is a TSB that addresses this.  I do not remember what year/models were covered.  I believe the fix is a redesigned torque converter so it makes sense a rebuilt old one would present the same issue.

Link to comment
Share on other sites

11 minutes ago, silverton said:

I believe there is a TSB that addresses this.  I do not remember what year/models were covered.  I believe the fix is a redesigned torque converter so it makes sense a rebuilt old one would present the same issue.

Copy that.

I've seen the TSB. its for years 08-09.

Plot twist. The TC rebuilder said he installed an updated spring in the TC.

I'm gonna have to go through my records to get an exact PN for this.

Going to try Shudder Fixx soon as a last hail mary...

Link to comment
Share on other sites

25 minutes ago, silverton said:

'fix in a can' never works, but I suppose it could be worth a try.

I 100% agree with ya.

But if I'm already counting the tranny as a total loss.. what's another $20..

I'm gonna make a video too.. Will post to YT even of it doesn't work.  

  • Like 1
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share



×
×
  • Create New...

Important Information

Terms of Use