Jump to content
LegacyGT.com

Rattling noise - wheel hitting housing?


Recommended Posts

2005 LGT stock VF40 turbo. 102K miles. So I have this rattling noise that I hear when engine is running. Pretty much the same either cold or hot engine. I thought it sounded like a heat shield rattle but I do not have any heat shield on my CNT down pipe. Seems to be coming from the turbo area. I tried to pull off the down pipe to check shaft play but those bolts aren't coming loose. Can I check the shaft play by pulling off the air intake tube? Is it relatively easy? Tried to see from the intercooler inlet but the compressor isn't visible.

 

Thanks, Ralph

Link to comment
Share on other sites

I don't believe so, that would be very difficult.

 

Have you tried spraying the nut's bolts with PB Blaster something like it ?

 

I use Aero-Kroil The stuff is amazing.

 

Others say Automatic tranny fluid and acetone mixture at 50/50 mix works well too.

 

 

I bolt the turbo to the up pipe.

DSCN4783.thumb.JPG.6b814e21fcc8161acd6ab0abaa27bafd.JPG

305,600miles 5/2012 ej257 short block, 8/2011 installed VF52 turbo, @20.8psi, 280whp, 300ftlbs. (SOLD).  CHECK your oil, these cars use it.

 

Engine Build - Click Here

Link to comment
Share on other sites

Got the downpipe off. It turns out the wastegate flapper puck is loose and not making contact with the bypass hole. The actuator is jammed. Took off the actuator and pushed and pulled it a few times. Seems ok now. If it jams again will look for a replacement. Thankfully the shaft us tight with no play.
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share



×
×
  • Create New...

Important Information

Terms of Use