Jump to content
LegacyGT.com

Canadian 2010-2014 instrument cluster


Kengurius
 Share

Recommended Posts

Hello,

 

Maybe someone has legacy/outback 3.6 instrument cluster from Canada with (km,100km/l)?

 

I'v got USDM outback and trying to convert it to metric system, all would be fine but I just can't get fuel consumption right, all the symbols are okay now (l/100km, celcius and so on) but calculation of fuel is wayy wrong.

 

tldr: just hoping maybe someone made eeprom dump of this instrument cluster and is willing to share it with me.

 

p.s it is from 93c86 chip on the cluster.

Link to comment
Share on other sites

That would be super strange since it is known that people make this just from dashboard reflash.

I would guess maybe dashboard see injector "open-time" rather than final value.

p.s I was able to change it from MPG to kilometers per liter (I guess some countries use this type of calculation) however unable to do l / 100km yet :)

Link to comment
Share on other sites

Hello,

 

Maybe someone has legacy/outback 3.6 instrument cluster from Canada with (km,100km/l)?

 

I'v got USDM outback and trying to convert it to metric system, all would be fine but I just can't get fuel consumption right, all the symbols are okay now (l/100km, celcius and so on) but calculation of fuel is wayy wrong.

 

tldr: just hoping maybe someone made eeprom dump of this instrument cluster and is willing to share it with me.

 

p.s it is from 93c86 chip on the cluster.

 

What cluster do you refer to? monochrome (old) or color (facelift)?

Link to comment
Share on other sites

How did you change from MPG to L settings? Changes cluster dump? Where did you take KM info from? Do you have your original dump file and changed one? And how inaccurate are the readings now?

 

 

Hi, yes I have modified original dashboard dump, it is combination of several dashboards and other information I was able to find online.

 

Looks like I was mistaken, it shows bad consumption l/100km because it is "counting" miles, not kilometers (trip ODO). Hopefully I will manage to change this without screwing all other things, it is quite hard to do it on "trial by error" method :)

Link to comment
Share on other sites

Upload original dump in public resource and send me a link to it. You can also add your wrong dump file to take a look.

 

https://drive.google.com/open?id=1Z9ZMbay3Cqm1eplqhSyipNH490PXrt59

 

Here you go, not sure if modified is latest - but it should be.

 

p.s If you know what/where can be changed, would love to learn anything you have :)

 

I'v started all of this more from learning side :)

Link to comment
Share on other sites

https://drive.google.com/open?id=1Z9ZMbay3Cqm1eplqhSyipNH490PXrt59

 

Here you go, not sure if modified is latest - but it should be.

 

p.s If you know what/where can be changed, would love to learn anything you have :)

 

I'v started all of this more from learning side :)

 

I will check during this week. I'm not a pro dump content digger as well but i have some thoughts :)

Link to comment
Share on other sites

What is the desired car region for you? Canada or Europe?

I will refer to your original dump first line:

6A 2B FF AA FF AB 96 0F 26 10 FF FF FF FF 07

 

For Canadian region:

6A 3B FF AA FF AB 96 09 30 10 FF FF FF FF 07

 

For European region:

6A 4B FF AA FF AB 96 09 40 10 FF FF FF FF 07

 

Rest lines make no sense AFAIK. Please change and report.

Bytes for changes highlighted in bold

Link to comment
Share on other sites

Yup, all works fine, your first line + my other mods below to correct speed. all good now :) thank you !

 

Very good.

I think your "other mods below" are useless, as pointer uses one movement algorithm no matter of Miles or Kilometers, as US speedometer dial has both on it (Miles big digits, kilometers - small digits) and these are shown as one next to the other.

 

I think you could just accidentally use a piece of JDM cluster dump with maximum 180km/h on the dial which made your pointer move faster than it should. So IMHO - you shouldn't be doing this change at all, as your speedometer had to show the speed correctly without any dump changes.

 

The only reason for speed pointer algorithm change (IMHO) is when you use cluster from a different car with different tire size, as for example in my case: it was around 10km/h difference as my new facelift cluster is from Outback but i have legacy - tire size difference caused this gap and I had to adjust the pointer to move a little slower as it should +3km/h to GPS measurements.

 

Anyway - all works for you fine now. Very good. You are welcome.

Link to comment
Share on other sites

  • 2 years later...
Ouch... it is unlikely that anyone can find Canadian devices now because now everything is breaking down and being replaced by a Chinese replica. Most torpedo repairs are preceded by the partial or complete dismantling of the dashboard. But first, it is essential to familiarize yourself with the technical documentation of the car to understand where the fasteners are, etc. After following the technical documentation, the torpedo is removed. This, as a rule, involves unscrewing the fasteners, snapping the latches, removing the steering wheel from the lining casing. To completely dismantle the panel, two hands will not be enough. You need to have at least a clamp https://www.sandfieldengineering.com/toggle-clamps / or another person... Edited by stefangrim
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share



×
×
  • Create New...

Important Information

Terms of Use