Jump to content
LegacyGT.com

Losing commercial radio presets?


Recommended Posts

I've read the posts about losing XM presets but I've got the opposite problem. Recently, at random times, I lose the presets to all commercial radio stations I have while the XM ones are fine. I had the HU and Nav software updated to latest levels back in Dec iirc. Did not find related posts. Anyone else had this happen?

 

Figure to have dealer look at it when I go in for distance remaining recall fix.

Link to comment
Share on other sites

I had the same thing happen, they flashed an update that has since been dropped, it was a really bad update, then entire head unit had to be replaced. There is no real remedy currently as of now. I check in the daily since I work at a Subaru dealer, they may need to order a new radio, mine has been working as designed since they replaced the radio, this was about 3 weeks ago

 

Sent from my SM-G975U using Tapatalk

Link to comment
Share on other sites

  • 3 months later...
happened to me also. does it require a stealership fix?
It does require a visit there, I haven't seen a update for it though, mine did end up wiping out my FM presets again, but it's better than it used to be. I'll look into seeing it they have an update for that tomorrow

 

Sent from my SM-G975U using Tapatalk

Link to comment
Share on other sites

I think it may be endemic to a hardware fault in the head unit. My old one did this along with some whacky audio and mixer issues. Only thing that fixed it was a new head unit. 3 months in and it’s been good.
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share



×
×
  • Create New...

Important Information

Terms of Use