Jump to content
LegacyGT.com

Sunroof issue


Recommended Posts

Sorry for starting a new sunroof thread, but I searched all existing threads and cannot find my specific issue.

 

I have a 2002 Legacy GT Limited and last year my sunroof started giving me problems. The tilt opens and closes fine. However, when I use the internal sliding open/close switch the sunroof opens fine, but then I can’t close it. When I actuate the switch to close the sunroof, 90% of the time nothing happens. No motor noise, no buzzing, and nothing to indicate it’s a debris blockage. I inspected it and the tracks are clean.

 

Last night I tried again. On one attempt it did close and worked normally, but after that I couldn’t get it to work at all and had to close it manually with the Allen wrench. Of course when this first happened I tried replacing the switch, but no change so I reinstalled the original switch to get back to diagnosis ground zero. I tried disconnecting the battery for five minutes. Zip.

 

Before going to a sunroof expert or the dealer, I’m wondering if anyone has has encountered this and/or have suggestions. Thanks for considering my issue.

Link to comment
Share on other sites

Thanks. I’m assuming power isn’t an issue since the motor seems to work fine and the roof opens normally when I hit the switch. No binding and not slow. Tilt open and close works too.

 

It’s like the switch is inoperable when I try to close it, and there’s no change after installing a new switch. But sometimes it does work and when it does it closes normally.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share



×
×
  • Create New...

Important Information

Terms of Use