Jump to content
LegacyGT.com

2008 forester 2.5 NA - crank, no start


Recommended Posts

Just posting to hopefully save someone some time.

 

Wife forester was cranking fine, no start. 101k miles

 

Hooked it up to FreeSSM. Had injector pulse and crank sensor was reading ~170 rpm on crank. Checked for spark at the cylinder ... none.

 

Coil was replaced about 4 months ago due to a failure. Seemed unlikely it failed again. But you never know. Checked the wiring and resistance, checked out fine.

 

Battery was showing 12.5v across the terminals. On crank the voltage was dropping signicantly at the battery. Battery was less than a year old. Had it load tested at the local AutoZone and the battery was bad.

 

Never had a battery turn the car over normally, but not be able to provide enough voltage to fire the coil.

 

Moral to the story? Don’t assume because the car turns over fine your battery is good.

 

Replaced the battery, and it fired right up.

Link to comment
Share on other sites

  • 1 month later...

So I thought I had it fixed, but apparently the new battery was just masking the issue. So here is where I am:

 

Car will crank fine, but no spark. Issue only happens when the engine is cold and outside temperature is below about 30 degrees F. usually the first start of the day.

 

Using an inductive timing light I have confirmed the issue is no spark. The plugs are wet with fuel.

 

Using FreeSSM I see:

 

No CELS set or pending

 

Coolant temp: -7 deg

Intake air temp: -6 deg

MAF responds to incoming air when cranking

Injector pulse occurs when cranking

With starter cranking I see ~170 RPM

 

I replaced the plugs

I cleaned the all the grounds I could find with a wire wheel (2 side by side on passenger intake, one on RT frame rail behind radiator, one on RT strut tower, one on the bottom of the dogbone up to the firewall, one on starter, one on top of left frame rail behind battery and the battery terminal itself.

 

I also used a jumper cable from the neg terminal to the top alternator bolt and tried it - no spark - so I'm pretty confident its not a engine ground issue. I could not find one that looked to be the ECM ground, but it communicates with FreeSSM.

 

I have been able to start it every time using my 450amp engine starter. It's screaming a weak connection somewhere but for the life if me I can't find it.

 

So my questions are:

 

did I get all the grounds? If not where are the other ones. This seems like a grounding issue.

 

What triggers the coil to fire? The crank sensor obviously works because freeSSM is seeing RPM. Cam Sensor maybe? if there was no signal I would expect a CEL. It's also got injector pulse which leads me to believe that is not the issue.

 

Thoughts on where to go?

Link to comment
Share on other sites

Some more info.

 

It’s damn cold out here in NEPA!

 

I did a voltage drop test on the ground to see what if anything it would tell me.

 

Cranking the voltage drop was 250 mv on the main ground cable connection. It was the same from the block to the negative terminal.

 

I put the engine starter on it (450amp) and it fired right up.

 

running the voltage drop was 30mv at both the ground cable and the block.

 

Those numbers seem to be acceptable from everything I have read.

 

Help! This thing is driving me nuts.

Link to comment
Share on other sites

I feel ya buddy, I'm experiencing the same exact issue with my girlfriends 2008 legacy. Wont get spark when its cold, I had a code for a crank sensor at one point and replaced the sensor and still have the same issue (possibly a ghost code from excessive cranking and no start). The battery is about a year old. This issue has been occuring since last winter. I tried finding a control signal pulse from the PCM at the connection for the coil and wasnt seeing anything from the computer. Only had 12v power on 1 of the 4 pins and no signal from the other 3 (im not sure what pin(s) its supposed to be on but I figured I see something out of the other 3). Which tells me the PCM isnt sending the signal to engage the coil. So either my PCM is bad or a bad connection somewhere or PCM isnt getting the required inputs to send the signal. I would think if it was missing another input like a cam sensor that it would trip a code. BUt I havent had any codes other than the 1 crank sensor code.

 

I really hope you find a solution as your issue sounds identical to mine. If you find a solution please let me know. My car has been at dealership for 2 weeks waiting for a diagnostic.

Link to comment
Share on other sites

I'll keep this post updated. Its really acting like a bad ground, but it doesn't test that way.

 

When it acts up again I'm going to back probe the coil 4 pin plug and check the positive side and see what kind of drop i get. Could be a harness plug has some corrosion, although I wouldn't think temperature would effect that.

 

If this helps you in your case, I attached the coil wiring diagram for the 2008 legacy 2.5. This is the non turbo. If you need the turbo or H6 let me know.

 

Looks like on your 4 pin plug on the coil, pins #1 and #4 are the signal wires, #2 is the 12V and #3 is the ground

Capture.PNG.d77224d919a663be2e35fcb9ccd37090.PNG

Edited by poconoracing
Link to comment
Share on other sites

It's unlikely, but I've wondered about something for awhile.. Do you think the coil gets any ground at all from the intake manifold? Where the brass(?) spacers make contact with it, or maybe from the screws.. Just attached the random picture for a visual of that here.

 

Do you still have the little black plastic spacer in the negative battery terminal? That stupid thing was limiting how tight I could get the terminal on the post.. Unlikely again, but why not throw it out there.

 

One more small thought, what brand of coil is it? Poor contact between the wires and the coil? Some plugs/wires don't snap in, but I would think you'd still get the engine to start, and maybe just misfire..

ngkcoil.thumb.jpg.94ffb9018b03b0138d1d2e8ce86e1d7a.jpg

Link to comment
Share on other sites

The ground side terminal is cleaned and tight. According to the wiring diagram it dopes not appear the coil grounds at all through the body. But its a good question!

 

Coil was a ac delco I believe from Autozone. Was not the duralast. It's about 5, maybe 6 months old now. Original was replaced due to an intermittent miss when it was damp/rainy.

 

I pulled the 4 pin plug on the coil. The car started right up so no sense in checking the signal. Power and ground both tested fine. No visible corrosion, I used electronics cleaner and sprayed it and pins down good.

 

I went after the positive side of the circuit. I did find some corrosion on the positive lead for the power distribution block. I took the terminal apart and cleaned it. I pulled every plug i could find along the path from the coil back to the battery, nothing jumped out as damaged or corroded. It's too warm today for it to act up (about 35 degrees) so I'll have to wait for another cold snap to see if we have a fix.

 

Its frustrating, no obvious issues :spin:

Edited by poconoracing
Link to comment
Share on other sites

12 degrees F this morning at 7am.

 

cycled the key a few times before i tried it the first time

 

took 5 ~10 second cranks before she would fire, but it did eventually start without a jump. It did not lop along or try to catch. Just cranked. Once it fired it ran perfectly, no miss or hesitation. Went to work, car sat for 7 hours, came out and it fired right up. Temperature was about 27 degrees.

 

Just in case there was something wonky inside the coil, like the cold affecting a pin connection or something, I took it off. Warranteed it at Autozone. It's free and a 15 minute replacement, why not?

 

And Apexi I took to wire wheel to the mounting points on the intake just in case...

 

I dont like breaking out the parts cannon, but I'm at a loss.

Link to comment
Share on other sites

Well hello fellas, i cant believe we have the exact same issues below 32F.

2007 Legacy 2.0R EJ204 121 kW (European version)

Also suspect the Spark plugs, coils, or ground connection. How about the B21 connector from the poconoracing capture? Or maybe merely broken wire?

Link to comment
Share on other sites

Mines at dealership still, I’ll let you know what they find out. I’m really starting to suspect that the PCM has gone bad. Often times the only electronics that fail in cold are the ones with circuit boards with cold solder joints. Often times the cold causes the components to contract and the solders come apart. This is a common issue with the passenger airbag indicator on the roof in front of the car. I’m not gonna replace an expensive computer on a whim though which is why I went for the diagnostic. We’ll see what they say.....
Link to comment
Share on other sites

Just got a call from dealership, they had the no start occur today and yesterday and came back with a decent diagnosis (for a change, last time I was told to clean throttle body for a no spark condition lol). They determined the wiring for the crank sensor had corroded and frayed inside the wiring harness, between the sensor and the connection for the computer. Not far back from the sensor itself. They said they were able to reproduce the issue by moving the wire around (don't know if I trust them on that tho). They wanted 375 for the work plus the diagnostic. I told them to go ahead and do it (usually I do my own work, first time at a shop/dealership for anything). One reason I'm not is I'm sick at the moment, and two if the issue occurs again I can go back for another free diagnostic. I'll let you know how I make out. I kind of figured it was either a bad wire/connection or the computer. I hate chasing wires though.... I wont say its solved yet though until I see it start in cold weather a few times.
Link to comment
Share on other sites

Have inspected the crank sensor area and found a bit of leaked steering fluid on the connector/wiring. Cleaned the area and seems to crank and work nicely for now, but ambient temperatures are above 32 F (2 Celsius) and I can't confirm it works on the colder weather, but i hope it should.

Thanks for thread and advises! Any news from your dealer?

Link to comment
Share on other sites

So the saga continues....

 

Was 15 degrees this am, and still crank but no start - no spark

 

Going back over it in case i missed something i pulled the coil again.

 

Resistance 10.58 ohms across the towers, it's an integral igniter design. service manual says 10-12 ohms is acceptable for the secondary, primary cannot be tested

 

4 pins on the connector - key on

 

1&4 are the signal wires - cranked it with the multimeter attached and it was showing varying voltage with an average of about 3 volts - I dont have a scope - it appears i have control signals

 

pin 2 was battery voltage - consistent with the wiring diagram

 

pin 3 showed nothing - putting the power probe on it showed a ground - that wire goes back to the ECM per the diagram so i did not power it to check the condition of the ground. didnt want to fry the ecm

 

While I had the coil out I uplugged the main harness (B21 Connector)to the firewall and plugged it back in. It's cold and i did not want to break the retainer so I did not force it all the way apart, just as far as the gray lever would open it. No crumblies came out of the connector when I opened it.

 

I cant find a spec on pin #3 it in the FSM, anybody know what should that pin 3 reading be? or is it simply a ground. I attached the diagram.

 

The battery was getting down (about 11.6V) from all my attempts to crank it. Put the 2 Amp charger on it for about an hour while I ate some lunch. Came back out and it fired right up. WTH!!

 

This thing is screaming a bad connection, but I'll be damned if I can find it.

 

Tomorrow the plan is to pull the ECM and test it's power and all it's grounds 5 from the diagram.

Capture.thumb.PNG.f812c82ecf8c1a83618203faf5866b29.PNG

Edited by poconoracing
Link to comment
Share on other sites

Koral33fer - I'm glad they found your issue, at least we think. I did visually inspect the wiring for both the cam and crank sensors. Could not get the multimeter down there to back probe the crank, but the cam sensors resistance was ~1.58 ohms - in spec. I also have an rpm signal in freessm when cranking so I'm confident crank sensor is ok.
Link to comment
Share on other sites

Key on, engine off

 

#1 - 0V

#2 - Battery Voltage

#3 - 0V

#4 - 0V

 

Key on, idling

 

#1 - 1 - 3.4 V Waveform - I dont have a scope, using the multimeter it should be variable voltage between 1 and 3.4

#2 - Battery voltage - 12-14V

#3 - 0V - (Ground)

#4 - 1 - 3.4 V like #1

Link to comment
Share on other sites

Update in my scenario,

Cold temperatures, cranking, but no ignition.

After few days/week of long cranking in the cold have drained a car battery a bit, after cranking few times the voltage also dropped to 11.6V - that is called a totally exhausted battery and needed a proper recharge - which i did for 24 hours - now it shows 12.6V.

After your thread read I inspected a Knock sensor, I wiggled the wiring and the ignition process improved I think that it might be a merely broken wire somewhere in the way to connector B21. For now I locked wires in "superposition" and engine starts normally on cold mornings and idling also improved.

 

Sometimes while driving and then I push on the pedal I get some jerking I think this is interconnected with knock sensors readings, (firstly I suspected the coil packs or a spark plugs).

And rarely but sometimes after turning off the engine, and on restarting the engine - cranking, but NO start. Reconnecting the main B21 harness always helped to be able to start the engine, but acceleration hesitation remained.

Planning of removing the whole wiring harness from the engine (B21 harness part) and doing a detailed wire inspection.

Also will clean the ground connector points.

Edited by Nanolized
Link to comment
Share on other sites

It's unlikely, but I've wondered about something I read in the Subaru factory service manual. There is something about how the knock sensor wire has to be at a certain angle. I can't look at the FSM now, but the link below has the picture I'm talking about, but I'm not sure what year/model Subaru it's for.

 

https://www.bobistheoilguy.com/forums/ubbthreads.php/topics/3632841/Specific_Angle_for_Knock_Senso

Link to comment
Share on other sites

  • 2 weeks later...

So it's been a full two weeks since I split the brass connectors on GE1 (passenger side of intake manifold) and cleaned all the corrosion out of between them with a wire wheel.

 

Not a single crank/no start. Had a couple of mornings in the 12-15 degree F range.

 

Fingers crossed I got it.

Link to comment
Share on other sites

No success with my repair at the dealership. They wanted 375 for the diagnostic and the repair, I waited for a cold morning to pick up the legacy and it wouldn't start in their parking lot. So I ended up paying for the wire repair $200 and got out of the diagnostic charge. Still having the issue though. I'll have to try repairing that ground you mentioned. I cleaned the contact itself but never took it apart to do a real through cleaning. Edited by koralr33fer
Link to comment
Share on other sites

I'll tell you this has been one of the most frustrating issues I have ever come across.

 

The pic is the grounds I'm talking about. Its not my car, but mine are in the same spot. One of them is actually 2 connectors, and they fit together. You have to pry them apart. You'll see they are ridged to fit inside each other. Pull them apart and clean them good with a wire wheel. Mine had a film of white corrosion in the grooves. It really didn't look as bad as I would have expected to cause a no start. Voltage drop also tested fine on the bolt head. From the wiring diagram those are the ECM grounds for the ignition coil.

 

Wife hasn't had a no start since I did it.

 

Good Luck

grounds.JPG.6a0f31396a04902afefb9ac2bd7e02da.JPG

Edited by poconoracing
Link to comment
Share on other sites

  • 2 weeks later...

The battle still wages on for us, I tried cleaning in between those connectors and have already cleaned the other grounds and the terminals. Today I tried troubleshooting using a FSM for no spark condition. Probed the connecter to the coil pack, got 11.6V on pin 2. Checked 1 and 4 and got voltage bouncing from 0 to 1.5 volts while cranking (I’m assuming an ok signal). Pin 3 goes back to the ecm, I got down into that and probed the connections there per FSM. 1.0 ohm resistance so got continuity back to ecm ground.

Checked resistance on coil pack, seemed ok. FSM said to replace coil pack anyway since voltage on pins 1 and 4 of coil connector varies less than 10 volts. Got a coil just to eliminate it and still have no spark on any cylinders....idk what’s going on. Also checked for crank signal and cam sensor signal on ecm while cranking, can see varying voltages so assuming they are working ok and resistances for about 1.5k ohms on each circuit. Can also read rpms on scanner while cranking. No codes or history while scanning on snap on Solis. I’m stumped at this point...:confused: Anyone got ideas at this point?

 

PS also tried to jump for extra juice, no effect

Link to comment
Share on other sites

Sorry to hear you are still having the issue. TBH I'm still not 100% sure mine is fixed. Fingers crossed.

 

I attached the ECM pin specs for the 2008 legacy. If you were reading at the ECM, then those voltages 0-1.5 were lower than the FSM is calling for, maybe the drivers in the ECM are giving up the ghost. Voltage is about half. One thing to note is the car needs to be running to do these checks, so you may have to wait for a warmer day.

 

If you were reading that at the coil, you have a voltage drop between the ECM and that coil 4 pin plug. Odds are it's a corroded pin or connector. Possibly the ECM main power and/or grounds are weak, causing the low output. Check those too. They are all on the attached 5 pages.

2008 2.5 NA ECM IO signals.pdf

Link to comment
Share on other sites

Tried starting the car this weekend in the 30’s when it would usually start and couldn’t get car started at all Friday or Saturday. So I figured I had jostled something loose when checking wires on coil and at ecm and now had a complete failure. Which is almost better if you ask me. Got it towed to my dad’s who has a nice garage instead of working out in my cold driveway like I have been.

 

Checked all the stuff at coil connection, got power and ground back to ecm. Checked for signal using an oscilloscope and was only getting a very weak waveform on 1 and 4 the control signals so figured we had no signal, just seeing noise from cranking the motor. Checked for continuity for all wires back to the computer and load testing them with ECU disconnected. Plugged ECU back in and I checked for cam and crankshaft waveforms while cranking with oscilloscope at ecm. Both looked okay. Checked all ecm grounds and voltage inputs. All ok, at this point I was certain it was the ECU. But just for shits and giggles we tried wiggling the wires and connections at ECU while cranking, and she fired! Moving the wires would cause to start and than not. Ended up being a loose connection within the plug itself, although the plug didn’t appear damaged or corroded. The wire that was loose was one of the wires for the control signal.

 

I ended up doing a rather unorthodox repair in lack of having a spare connector handy and being unable to get the wire out even with a set of terminal keys to use. So....we forced out the 2 signal wires for control signal and drilled out the pin holes in the connector. Then we soldered 2 small wires to the pins of the ecm itself, then fed the wires through the connector and spliced them in to the existing signal wires.....vroom vroom!

 

There is a chance that this connection became loose during my probing. But it would explain why I had no spark, a new coil, and no engine codes. If I was missing an input like cam or crank it would likely send a trouble code. But if there was an issue with the signal output that would not be detected as they are sent by the computer and not monitored afterward. Looks like Monday and Tuesday should be cold, I’ll know by then if I got it *fingers crossed*

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share



×
×
  • Create New...

Important Information

Terms of Use