Jump to content

Blue Tooth Device Error when attempting to delete from List

Recommended Posts

Has anyone every encountered an error when attempting to delete phones from Blue-Tooth manifest?


I keep getting an error, I have tried restarting, removing batt from car. etc etc.


any help would be great



Step 1



Step 2 - Select device to remove







Step 3



Link to comment
Share on other sites

I had the same issue with my 2013 Legacy 3.6R shortly after I got it.....the Blue tooth just did not want to delete my old phone :( I just kept trying and after about a dozen attempts it worked fine..... It has worked perfectly ever since :)

Keep trying ;)


And make sure the phone you are trying to delete is no where near the car....that was part of my issue...the phone I was trying to delete was in the house about 50 feet away but I guess the BT could sense it.

Link to comment
Share on other sites

haha, thanks for your response.


Actually, none of the phones on the list are even mine except the last one.


the first entry is the original owner and it wont delete.. Everything after that wont delete either except my own.


The only reason its a problem is because it seems to take about 45sec- 1 min to connect to my bluetooth. I believe its cycling through every phone chronologically until it finds something to connect to.


I remember about a year ago I was able to delete all but 1 (The original owners iPhone,) and it would connect in matter of seconds. Now with more on the list that I cannot delete, it takes what seems like forever.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Create New...

Important Information

Terms of Use